[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] composed characters in LaTeX source code

From: jfbu
Subject: Re: [AUCTeX] composed characters in LaTeX source code
Date: Thu, 8 Nov 2018 23:27:40 +0100
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:52.0) Gecko/20100101 Thunderbird/52.9.1

Le 08/11/2018 à 22:56, Stephen Berman a écrit :
On Thu, 8 Nov 2018 21:48:34 +0100 Joost Kremers <address@hidden> wrote:

On Thu, Nov 08, 2018 at 09:08:51PM +0100, Stephen Berman wrote:
Thanks.  I ran it through XeLaTeX and that indeed output the composed
character correctly aligned, though the vertical positioning looks worse
to me than with pdflatex (see attached screenshots; text0.pdf is with
pdflatex and text1.pdf with xelatex).

That may be a font issue. My preferred font is Linux Libertine, and as you can
see in the attached image, things look a bit different: the accents on b are
shifted slightly to the right so that they do not cross the ascender of the
b. Compare with p, where the accents are placed more centrally over the

You're right, it depends on the font used.  Though it seems strange that
pdflatex and xelatex display the combining circumflex accent differently
with the same font (assuming it was the same font, I just used whatever
the default was).

It is not exactly the same font, because LaTeX uses the Latin Modern OpenType 
font with XeLaTeX and the Latin Modern TeX font with PDFLaTeX.

Also, to make this AUCTeX-related, after setting LaTeX-command to
xelatex and typing C-c C-c in the test1.tex buffer, the compilation
failed with the uninformative message "LaTeX: problems after [0] pages"
and no log output.  But running xelatex from the shell worked fine.  Is
there something else necessary to use XeLaTeX in AUCTeX?

Have you checked the output of the TeX command with `C-c C-l` to see if
there's a more informative message? I've been using XeLaTeX for so long that I
don't remember if there's anything special I needed to configure. All I know
is that I have `TeX-engine` set to `xetex`.

Thanks, that was it.  (Setting LaTeX-command was definitely wrong: it
resulted in AUCTeX trying to run "pdfxelatex".)

Ah ok.

Steve Berman

reply via email to

[Prev in Thread] Current Thread [Next in Thread]