[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX] Headache: filenames with Umlaut under Windows, backward search

From: AW
Subject: [AUCTeX] Headache: filenames with Umlaut under Windows, backward search gives error
Date: Thu, 26 Sep 2019 12:29:34 +0200


Emacs 26.3, installed not long ago on Win 8.1. Texlive 2019, up to date.

I'd like to get rid of the need to replace an Umlaut (äöüÄÖÜ) and "ß" in 
filenames. One of the reasons is a naming convention for files in my job.
For outgoing letters the filename includes the name of the recipient and in 
Germany the name often includes an Umlaut. 

But whatever I try, with an Umlaut in the file name the way back from the PDF 
into the *.tex file using synctex doesn' work under Windows 8.1, while under 
Linux (openSuse Leap 15.1) there is no problem. Under Windows, if I click into 
the PDF, I get an error.

( LaTeX moves as well, F. Mittelbach has written "utf8andspace", which I can 
include with "\input ..." and have Umlaute wherever I want. By the way: the 
label mechanism doesn't accept Umlaute yet. Is there a variable which I could 


== == ==



Text müt Ümläütön.

== == == 

For good measure I named it ÜmläutÖ-täst.tex. 

As long as I don't tell Emacs anything about encoding, the file compiles. I 
deleted all the commands in the .emacs regarding enconding. 

After compiling I'm using pdf-tools to view the PDF and Emacs opens the PDF, 
no problem. The file ÜmläutÖ-täst.synctex.gz is present. Using dired, I can 
even open it, it starts with the lines

== == == 
SyncTeX Version:1
== == == 

It ends with the lines

== == ==
Post scriptum:
== == ==

But if I click on the Text in the PDF (in Emacs), I get:

== == ==
pdf-info-query: epdfinfo: Unable to create synctex scanner, did you run latex 
with `--synctex=1' ?
== == ==

Yes, of course, as output* tells:
== == ==
Running `LaTeX' on `ÜmläutÖ-täst' with ``pdflatex -synctex=-1  -file-line-
error  --synctex=1 -interaction=nonstopmode "ÜmläutÖ-täst.tex"''
== == ==

I opened the PDF with SumatraPDF and clicked on the text, which tries to open 
in Emacs a non existent file \334ml\344ut\326-t\344st.tex

What I've tried to get the jump from the PDF into the *.tex-file working:

Probably pdf-tools gets the filename wrong, so I tried to customize Emacs, 

(prefer-coding-system 'utf-8-unix)
(set-language-environment "UTF-8")
(setq default-process-coding-system '(cp1252 . cp1252))

You know, if I had any succes, I wouldn't write this lengthy E-Mail. 

I haven't found a way to make it work and so here I am with this headache.

Kind Regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]