[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] build: avoid warning from coverity about lbitset_elt_find

From: Jim Meyering
Subject: Re: [PATCH] build: avoid warning from coverity about lbitset_elt_find
Date: Fri, 13 Jan 2012 12:00:49 +0100

Akim Demaille wrote:
> Le 13 janv. 2012 à 10:19, Jim Meyering a écrit :
>> Paul Eggert wrote:
>>> On 01/12/12 05:57, Jim Meyering wrote:
>>>> is there any objection to my running update-copyright
>>> No, that'd be fine, thanks.
>> Done.
> Thanks Jim!

Hi Akim,

> I ran it on branch-2.5 too.  But I don't think you
> have pushed your coverity fix.  Could you please also
> install it in branch-2.5?


I just tried to cherry-pick that commit from my
private branch onto master, but it failed due to ChangeLog
differences.  I can deal with that easily, but...
What do you think about generating ChangeLog from git log like
we do for coreutils, grep, gzip, diffutils, etc.?

> Would these bitset operations make sense in gnulib?  I
> had taken them from submitted patches for GCC, but IIRC,
> they never made it into GCC.

gnulib currently has no bit-set primitives, so they would definitely fill a gap.
Are you volunteering to package them?  ;-)

> About gnulib: when upgrading gnulib it sometimes happens
> (to me at least) that stray symlinks remain, which breaks
> "bootstrap" because aclocal dies on dead symlinks.  So
> I always remove symlinks that point into gnulib before
> running bootstrap.  Wouldn't that make sense into gnulib's
> bootstrap?
> (For instance:
> ...
> ./bootstrap: m4/threadlib.m4 overrides ._bootmp2/m4/threadlib.m4
> ./bootstrap: m4/wchar_t.m4 overrides ._bootmp2/m4/wchar_t.m4
> ./bootstrap: m4/wint_t.m4 overrides ._bootmp2/m4/wint_t.m4
> ./bootstrap: m4/xsize.m4 overrides ._bootmp2/m4/xsize.m4
> ./bootstrap: aclocal --force -I 'm4'  ...
> aclocal: aclocal: file `m4/dos.m4' does not exist
> )

The bootstrap script in gnulib already does this:

  # Remove any dangling symlink matching "*.m4" or "*.[ch]" in some
  # gnulib-populated directories.  Such .m4 files would cause aclocal to fail.
  # The following requires GNU find 4.2.3 or newer.  Considering the usual
  # portability constraints of this script, that may seem a very demanding
  # requirement, but it should be ok.  Ignore any failure, which is fine,
  # since this is only a convenience to help developers avoid the relatively
  # unusual case in which a symlinked-to .m4 file is git-removed from gnulib
  # between successive runs of this script.
  find "$m4_base" "$source_base" \
    -depth \( -name '*.m4' -o -name '*.[ch]' \) \
    -type l -xtype l -delete > /dev/null 2>&1

If you can wait a little while, I'll probably upgrade bison's
bootstrap to use the latest from gnulib.  I know that bison's
prefix-gnulib-mk usage would need a little tweak (just run
it manually on lib from bootstrap_epilogue), but other than that,
it might be trivial, since I've done the same to 4 or 5 other packages

reply via email to

[Prev in Thread] Current Thread [Next in Thread]