[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building bison from master fails: "conflicting types for 'code_get_l

From: Stefano Lattarini
Subject: Re: Building bison from master fails: "conflicting types for 'code_get_leng'"
Date: Sat, 19 May 2012 15:41:09 +0200

On 05/16/2012 11:07 AM, Akim Demaille wrote:
> Le 16 mai 2012 à 10:54, Stefano Lattarini a écrit :
>> On 05/16/2012 10:34 AM, Akim Demaille wrote:
>>> Le 15 mai 2012 à 22:45, Stefano Lattarini a écrit :
>>>> OK, I've re-done the check applying the patch to the top of maint, but I
>>>> see the same exact error as before.  Any clue?
>>> No :(  That's really weird.  Could you please provide me
>>> with one of the wrong generated scanner?  Maybe there's
>>> something wrong in the macros that define the version?
>> Sorry, I've been unclear; I meant: the *bootstrap* itself fails like this:
> Really, did you start from a fresh clone?  There are very nasty
> issues, such as dangling symlink for *.m4 files that breaks
> aclocal.  Be sure to, at least, git clean -fr.
I had indeed done "git clean -fdx" before re-boostrapping.

> Or just rm -rf in your bison directory and check out again.
I've tried from a freshly-cloned repository; same error.

But I've now found the problem: "bootstrap" doesn't initialize the
'autoconf' submodule!  If I do that manually:

    git submodule init && git submodule update

the bootstrap succeeds.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]