bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#12215: CSET is unnecessarily confusing


From: Paul Eggert
Subject: bug#12215: CSET is unnecessarily confusing
Date: Thu, 23 Aug 2012 20:57:48 -0700
User-agent: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120714 Thunderbird/14.0

On 08/23/2012 08:46 PM, Chong Yidong wrote:
> Maybe we could use macros that are a no-op under CPP, and serve only as
> guides for a non-CPP code transformation tool.

How about if we use a naming convention that the code transformation
tool could pick out?  That is, instead of

  bset_directory (b, current_buffer ? BVAR (current_buffer, directory) : Qnil);

we have something like this:

  b->Directory = current_buffer ? current_buffer->Directory : Qnil;

Here the convention is that the Lisp field names start with
a capital letter.  Almost any naming convention will do.

This is straight C, so the preprocessor would not need to be
used until we have a garbage collector that needs it.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]