[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Configure hangs at 'checking whether getcwd handles long file names

From: Paul Eggert
Subject: Re: Configure hangs at 'checking whether getcwd handles long file names properly...'
Date: Thu, 31 Oct 2019 13:04:32 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.1.1

In <https://lists.gnu.org/r/bug-tar/2019-10/msg00001.html>, Qingchuan Wang (qingcwan) wrote:

It hangs when ‘./configure’, I tried 1.29, 1.31 and 1.32, all same.

The ‘mkdir’ didn’t return peeking by /strace./

If mkdir did not return, that sounds like a significant bug in your kernel or filer or network. I could not reproduce the problem on a system similar to yours (RHEL 6.10, Linux kernel 2.6.32-754.23.1.el6.x86_64, in an NFS file system served by a Netapp filer on a local area network).

To help you diagnose the problem, I suggest running the the attached program in your file system. This program is derived from the 'tar' configure script. I ran the program on my system and got the attached strace output. If you get similar output, then the bug is in how 'configure' runs its program somehow. If you get output where the 'mkdir' syscall hangs, you'll have a simple test program that you can send to your sysadmins and help them find the bug with their setup.

I'll CC: this to bug-gnulib since the symptoms arise in Gnulib-derived code.

Attachment: getcwd-test.c
Description: Text Data

Attachment: getcwd-test.strace.gz
Description: application/gzip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]