[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

texinfo not happy with texlive not producing log?

From: Liviu Ionescu
Subject: texinfo not happy with texlive not producing log?
Date: Fri, 28 Oct 2016 01:08:38 +0300

I'm running some builds which also create pdf manuals, and I ran into the 
following problem:

Making install-pdf in doc
TEXINPUTS="/Users/ilg/Work/openocd/gnuarmeclipse-openocd.git/doc:$TEXINPUTS" \
        MAKEINFO='makeinfo   -I 
/Users/ilg/Work/openocd/gnuarmeclipse-openocd.git/doc' \
        texi2dvi --pdf --batch  --build-dir=openocd.t2p -o openocd.pdf  \
/Users/ilg/opt/homebrew-gae/bin/texi2dvi: TeX neither supports -recorder nor 
outputs \openout lines in its log file
make[1]: *** [openocd.pdf] Error 1
make: *** [install-pdf-recursive] Error 1

I'm using texinfo installed with homebrew:

ilg-mbp:~ ilg$ /Users/ilg/opt/homebrew-gae/bin/texi2dvi --version
texi2dvi (GNU Texinfo 6.3) 7353

texlive is built from sources:

ilg-mbp:~ ilg$ /Users/ilg/Work/no-backup/texlive/install/bin/etex --version
pdfTeX 3.14159265-2.6-1.40.17 (TeX Live 2016)
kpathsea version 6.2.2
Copyright 2016 Han The Thanh (pdfTeX) et al.
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Han The Thanh (pdfTeX) et al.
Compiled with libpng 1.6.21; using libpng 1.6.21
Compiled with zlib 1.2.8; using zlib 1.2.8
Compiled with xpdf version 3.04

if, instead of my compiled texlive I use the binaries provided by TUG for 
Darwin, I get the same result. but if I use the binaries packed as MacTex, 
texi2dvi succeeds.

after some debugging sessions, it looks like texi2dvi expects etex to generate 
an output log, or something like this, and if this does not happen, fails with 
"TeX neither supports -recorder nor outputs \openout lines in its log file".

+ tex_cmd='etex --file-line-error </dev/null '\''\nonstopmode'\'''
+ batch=false
+ tex_cmd='etex --file-line-error </dev/null '\''\nonstopmode'\'' 
'\''\input'\'' ./openout.tex'
+ verbose '/Users/ilg/opt/homebrew-gae/bin/texi2dvi: running etex 
--file-line-error </dev/null '\''\nonstopmode'\'' '\''\input'\'' ./openout.tex 
+ false
+ rm -fr openout.log
+ eval 'etex --file-line-error </dev/null '\''\nonstopmode'\'' '\''\input'\'' 
+ test -f openout.log                                           <<<<==== file 
missing with compiled texinfo     
+ grep '^\\openout..\? *= *`\?dum\.dum'\''\?' openout.log       <<<<==== test 
skiped with compiled texinfo
+ cd_orig

any suggestions why this happen?

thank you,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]