[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Calc; v p fails in script

From: Bart Nielsen
Subject: Calc; v p fails in script
Date: Fri, 20 Mar 2020 08:17:10 -0400

Please describe exactly what actions triggered the bug and the
precise symptoms of the bug.  If possible, include a backtrace by
doing `\[toggle-debug-on-error]', then reproducing the bug.

When I pack a set of vectors on teh stack in a keyboard macro, it fails
to do that when I run the keyboard macro.

In particular:

If I define a macro that builds a matrix from two vectors, the result on
the stack is my two vectors plus rev(2)

^x (
vx 2
2 vp
^x )

This defines a macro, which I named make.matrix.x2

(fset 'make\.matrix\.x2
   [?v ?x ?2 return return ?2 ?v ?v ?p])

when I run it, I end up with the following on the stack:

--- Emacs Calculator Mode ---
4:  [ [ 1, 2 ]
      [ 1, 2 ] ]
3:  [1, 2]
2:  [1, 2]
1:  rev(2)

I had to abort the macro with ^g to get it to show up.

Emacs  : GNU Emacs 25.1.1 (x86_64-apple-darwin13.4.0, NS appkit-1265.21 Version 
10.9.5 (Build 13F1911))
 of 2016-09-20
Package: Calc

reply via email to

[Prev in Thread] Current Thread [Next in Thread]