[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Confused by y-or-n-p

From: Juri Linkov
Subject: Re: Confused by y-or-n-p
Date: Mon, 04 Jan 2021 20:03:16 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (x86_64-pc-linux-gnu)

> Since y-or-n-p-use-read-key affects more than just y-or-n-p,
> perhaps it should be renamed to indicate that.

There is another variable that affects other cases:

> I propose the name single-key-answers. but I am not
> entirely happy with it.

Its name should be consistent with another variable
use-short-answers that could be used to replace
yes-or-no-p with y-or-n-p.  These two should have names
that preclude confusion between their meanings.

Also use-short-answers could be used by the existing variable

reply via email to

[Prev in Thread] Current Thread [Next in Thread]