[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with LaTeX class scrlttr2

From: Charles Millar
Subject: Re: Problem with LaTeX class scrlttr2
Date: Sat, 4 Apr 2020 08:01:55 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

On 4/3/20 10:30 PM, John Hendy wrote:
Thanks! Saves a lot of time to recreate an example.

I get the same error, but wouldn't you know I'm on TexLive 2019 which
must have just hit end of life... tlmgr says it's frozen and won't let
me try and add new packages. I do want to help but am not going to
update to 2020 for this :)

One thing popped out to me...

#+LATEX_CLASS: scrltttr2

Is that a typo (ttt, not tt)? If someone doesn't get to this before
me, I'll try again after I update TL 2020 over the weekend.

Probably the third or fourth time I entered a LATEX_CLASS, and the last time if was a typo. I corrected it to make sure and still have the same result.

Also, I had already added to my init file (require 'ox-koma-letter) and (add-to-list 'org-latex-packages-alist '("AUTO" "babel" t ("pdflatex"))) as instructed in the Worg tutorial.

On Fri, Apr 3, 2020 at 8:26 PM Charles Millar <address@hidden> wrote:

On 4/3/20 7:19 PM, John Hendy wrote:
Please attach an actual .org file so we can test/reproduce.

See attached
Generally "unknown latex class" means you don't have the package
installed. How about posting the output of this:

$ tlmgr list --only-installed | grep scrlttr2

No output; however I have TeXlive package, Debian testing, installed. I
found an example that uses scrlttr2 at


and ran it using TexStudio - no problem, i.e. resulted with a letter. So
I expect that scrlttr2 is installed as part of the TexLive komascript.

On Fri, Apr 3, 2020 at 4:06 PM Charles Millar <address@hidden> wrote:

I apologize for reposting - I forgot to complete my

-------- Forwarded Message --------
Subject: Problem
Date: Fri, 3 Apr 2020 16:49:15 -0400
From: Charles Millar <address@hidden>
To: address@hidden <address@hidden>

I am attempting to use ox-koma-letter, etc.

My set up

GNU Emacs 28.0.50 (build 84, x86_64-pc-linux-gnu, GTK+ Version 3.24.14,
cairo version 1.16.0) of 2020-04-03
Org mode version 9.3.6 (release_9.3.6-449-gb99357 @

org-latex-classes includes

"default-koma-letter" "\\documentclass[11pt]{scrlttr2}"

There are no other entries that include scrlttr2 in org-latex-classes

I have a barebones header

#+LATEX_CLASS: scrlttr2 (I also have tried 'default-koma-letter')

and then entered the Romeo to Juliet letter

and i receive the following error

Unknown LaTex class scrlttr2

I searched the list and one suggested problem does not seem to be
applicable - I do not have a mixed org installation.

Any suggestions.

Charlie Millar

reply via email to

[Prev in Thread] Current Thread [Next in Thread]