[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: wip-cite status question and feedback

From: Joost Kremers
Subject: Re: wip-cite status question and feedback
Date: Mon, 13 Apr 2020 12:10:25 +0200
User-agent: mu4e 1.3.10; emacs 27.0.90

On Mon, Apr 13 2020, Nicolas Goaziou wrote:
address@hidden writes:
What about allowing something more verbose? Perhaps
"cite-intext:" or "cite:intext:"?
The simple syntax is great for most cases, but if you want to support some of those not so common biblatex commands, this might be better.

Alphanumeric suffix provides 62 combinations, which should hopefully be
enough for any citation back-end out there (I'm looking at you
biblatex). It's not terribly readable, tho, as you point out.

62 combinations might sound like a lot, but if you want your cite commands to be mnemonic, you'll run out of options much more quickly.

This is a conciseness versus readability problem, not a technical one, as long as we do not allow too much, from a parser point of view.

I have no strong opinion on the topic. It would be more valuable to hear
from actual citations users. What would they prefer?

Not sure if my opinion counts, given that I mainly use LaTeX + biblatex to write my texts, but I would definitely allow more than one character. The more common commands (=citep=, =citet=) can still use a single character (and thus remain concise), but for less common commands, the ability to have more descriptive names is to be preferred. Imagine looking at a document you wrote a few years back and having to figure out what =citeQ= or =cite7= was meant for again, or finding that =citeF= was changed from =\fullcite= to =\footfullcite= because at some point the developers figured the latter would be used more often.

I don't think it's necessary to use a dash (or any other character) in longer cite commands, though. =citeintext= isn't that much more difficult to read than =cite-intext=. (Biblatex does just fine without dashes, and there's always camelCase if you're so inclined.)

1. For the bibliography:

#+bibliography: something.bib
(Could this be a list containing multiple files?)

Multiple keywords may be more appropriate, particularly if you need to
spell out absolute file names.

Org can provide a function listing all of them anyway.

Yes, and please make it a public (one-dash) function. :-)

2. Placing the bibliography with:

#+bibliography: here
(Ideally, it would be possible to have this multiple times, perhaps with some filters, like printing only the works of a certain author, or with certain keywords, or so. But that's, of course something for

It is smart, but I'm not sure I like using the same keyword for two
different things. OTOH, I don't have a better idea.

As someone already suggested, using something like =#+printbibliography:= would work. And if that is too biblatex-like, you could instead opt for e.g. =#+list-of-references:=. (Output formats such as HTML or epub don't involve any printing anyway, so... ;-)

Joost Kremers
Life has its moments

reply via email to

[Prev in Thread] Current Thread [Next in Thread]