[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: utf8 and unicode characters

From: Robert V. Baron
Subject: Re: utf8 and unicode characters
Date: Thu, 22 Apr 2004 20:52:21 -0400
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.3.50 (windows-nt)

Miles Bader <address@hidden> writes:

> On Sun, Apr 18, 2004 at 02:04:24PM -0400, Robert V. Baron wrote:
>> I want to use emacs to read/write utf8 files.  The files were generated by
>> translating chinese big5 files into utf8.  When I drop the files into
>> emacs, all I see is "y" with accent characters for each unicode character,
>> I can mouse over and emacs will show the character number.
> To make the current emacs handle chinese utf-8 correctly you have to have
> `utf-translate-cjk-mode' enabled (either do `M-x utf-translate-cjk-mode',
> or turn it on with customize-variable).
I NEVER would have guessed that.  And I don't thing I ran accross the magic
`M-x utf-translate-cjk-mode' before you mentioned it.  You should be sure
to put more web pages out that have the keywords of cjk and unicode and
utf-translate-cjk-mode so people can find the association.  I'd also like
to suggest that I think that the CJK support should be part of emacs.  I
can not believe it takes up that much space.

Let me run another question or two by you.  When I did not know the secret.
I looked around and found some unicode info by Markus Kuhn. He had a bunch
of ISO 10646 fonts for stuff including CJK.  So I made up a fontset with
his three ja/ko fonts.  When I used this with my utf8 chinese data, something
wierd happened.  The cursor moved forward thru the buffer really slowly and
left only empty space in its wake.  Also it took about 10-20 seconds to display
a few hundred characters.  Its possible that I messed up specifying the fonts.
Have you ever tried an ISO 10646 font with CJK characters.  If it works can,
you give me a pointer.

I tried another approach.  I explicitly called w32-select-font with an argument
telling it to allow variable width fonts -- I wanted to use MS Arial Unicode.
Nothing happened when I selected the font.  Should this work; it would be
neat to use MS fonts.

Where exactly are the fonts that emacs uses on w32?  I'm pretty sure that I
don't have any bdf fonts on the machine.  In particular, with 
on, some of the characters are missing.  I need to add them.

While I'm on the subject of (4/19/2004 cvs), I see a few bugs.
If I'm running an inferior process (shell or gdb), if i type a ^c, the 
interrupt will happen, but I also see the C-c in my buffer.  It also
seems that the print output of gdb gets buffered and does not appear
when the print is executed.  Further,  when I do a 'M-x info' and
type space in the buffer, it spaces forward vs visiting the entry on that line.

> [What do you mean "drop the files into emacs" anyway?]
Sorry for the sloppy terminology.  I read the files into emacs and wrote them
out again.  

But, all in all this emacs is pretty good.

> -Miles
> -- 
> (\(\
> (^.^)
> (")")
> *This is the cute bunny virus, please copy this into your sig so it can 
> spread.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]