[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: custom mode-line face makes Emacs freeze up

From: Stephen Berman
Subject: Re: custom mode-line face makes Emacs freeze up
Date: Sun, 31 Oct 2004 15:20:21 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/21.3.50 (gnu/linux)

On Sun, 31 Oct 2004 04:42:20 -0500 Richard Stallman <address@hidden> wrote:

>     Here's a specific pair: Type `C-x C-f test1', `test1', `C-x C-s', `C-x
>     C-f test2', `test2', `C-x C-s'.  Now customize mode-line face as
>     described previously (width=narrow, height=120, overline=on), then
>     invoke Ediff on test1 and test2.  Now Emacs goes into an infinite loop
>     for me.
> I tried this and it did not fail.
> Taking your instructions literally, the two files have no newlines.
> That's the way I tried it.  Is that what you meant?

Yes, in the test pair both files lack a newline.  However, that
doesn't make a difference here: when I add a newline it still fails.

>                                                      I invoked ediff
> with M-x ediff RET, then specified file test1, then file test2.

This is exactly what I do, and it fails for me every time with the
above mode-line face customization.

> Can anyone else reproduce this failure?

I would be mystified if no one else gets this behavior; I don't have
unusual hardware (a four-year old Samsung laptop with a Pentium III
CPU and a Savage IX/MV graphics card) or software (SUSE 9.0 with Linux
2.4.21).  Is the version of Emacs you tried my test with compiled with
GTK+?  I suspect the problem may lie there, since as I mentioned it
doesn't happen with CVS ntemacs under Windows XP, nor with the Emacs
that comes with SUSE 9.0, 21.3 compiled with the Athena toolkit.  (If
it were really necessary I could compile my CVS Emacs with the Athena
toolkit to see if I still get the failure, but I'd prefer it if
someone else could reproduce it.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]