[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

*shell* buffer forgets its limits

From: Peter Dyballa
Subject: *shell* buffer forgets its limits
Date: Sun, 3 Apr 2005 12:09:15 +0200


The *shell* buffer somehow introduces extra attributes or other strange things that make it quite unusable. Yesterday I copied a string form somewhere and in shell it was fontified as bold. Whenever I tried to paste (yank) with mouse yet another word between them the whole old sequence was high-lighted and replaced with the new word. I had to remove all text and face properties.

Another phenomenon is that the command line's end or beginning seem to be unreachable with C-e or C-a. End or beginning lie somewhere in the command line. An example:

From tcsh's history function I copied with mouse a command (foreach Glyph ( `cat ISO\ 8859-2.txt | grep -v '^;' | sed -e 's/ / /g' | cut -n -f 9 | cut -b 3-` ) ; grep $Glyph /Volumes/Halde/Schrift/Unicode/aglv2.0.txt ; end). On the command line this command starts according to C-a at "2" in the cat'es file's name, the end exists more than once, for example in the sed expressions TAB (s/SPC/TAB/g). When I enter with mouse the remainder of the command line, the end now is at the closing ")" -- and it's the line's beginning too because C-a does not move the cursor to another place.

Pressing now return I get the command repeated and a message:

        foreach Glyph ( `cat ISO\ 8859-16.txt | grep -v '^;' | sed -e 's/ /
        s/ / not found

The original command has become high-lighted ([comint-highlight-input]). Closing the shell buffer and opening new ones does not help, clearing the sed expression in *scratch* buffer does not help, today sed is broken (yesterday it worked to create a few PostScript encodings that way).

In GNU Emacs (powerpc-apple-darwin7.8.0, X toolkit, Xaw3d scroll bars)
 of 2005-03-31 on Latsche.local
Distributor `The XFree86 Project, Inc', version 11.0.40300000
configured using `configure '--without-carbon' '--with-x' '--without-pop' '--with-xpm' '--with-jpeg' '--with-tiff' '--with-png' '--with-gif' '--with-x-toolkit=lucid' 'CFLAGS=-I/sw/include' 'CPPFLAGS=-I/sw/include' 'LDFLAGS=-L/sw/lib''

Important settings:
  value of $LC_ALL: de_DE.UTF-8
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: de_DE.UTF-8
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: de_DE.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Major mode: Fundamental

Minor modes in effect:
  auto-compression-mode: t
  display-time-mode: t
  mouse-sel-mode: t
  show-paren-mode: t
  desktop-save-mode: t
  tooltip-mode: t
  tool-bar-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  global-font-lock-mode: t
  blink-cursor-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: t

Mit friedvollen Grüßen


"I love deadlines. I love the whooshing noise they make as they go by" (Douglas Adams)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]