[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Point of wrong window used in read-from-minibuffer?

From: Ulf Klaperski
Subject: Re: Point of wrong window used in read-from-minibuffer?
Date: Tue, 05 Apr 2005 10:59:27 +0200


Stefan Monnier <address@hidden> schrieb am 05.04.05 00:52:22:
> > - Load a vhdl file
> > - Divide emacs into two windows vertically, both showing the same buffer
> > - Jump to the end of the buffer in the upper window
> > - Switch to the lower window, near the beginning
> > - Type "signal " (with a space afterwards), this triggers the template 
> > insertion
> >   mechanism for a signal 
> > - type any name at the minibuffer prompt, eg. test and press return.
> > - type any type at the minibuffer prompt, eg. std_logic and press return.
> -> ! The region between the signal and the point in the other buffer is
> >     deleted ! 
> > - type any initialization value at the minibuffer prompt and press return.
> -> Error message: "byte-code: Invalid search bound (wrong side of point)"
> Can't reproduce it here.  I tried a few different cases but can't seem to
> trigger the behavior you describe.  Looking at the code, the only place that
> might look "suspicious" is the TAB expansion in the prompt, but even that
> seems to work fine.
> Can you try and give an even more precise recipe
> starting from "emacs -Q ~/tmp/newfile.vhdl" ?

Yes, the error does not occur with -Q.  I analyzed my .emacs to find the 
offending setting,
the problem is triggered by the following initialization:

 '(global-font-lock-mode t nil (font-lock))

A colleague tried it and came to the same conclusion: the problem occurs as 
soon as global font-lock is used.


Verschicken Sie romantische, coole und witzige Bilder per SMS!
Jetzt bei WEB.DE FreeMail: http://f.web.de/?mc=021193

reply via email to

[Prev in Thread] Current Thread [Next in Thread]