[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't isearch 'ö'

From: Peter Dyballa
Subject: Re: Can't isearch 'ö'
Date: Thu, 14 Apr 2005 20:56:11 +0200

Am 14.04.2005 um 19:49 schrieb Stefan Monnier:

Sorry, you went too fast for me.

Well, I feel your eMail came an our hour too late, I just had updated and recompiled to check the non-bug in Cua Customization Group ...

To start with, please mention if you're using my patch and/or any other patch.

I put your patch into src/keyboard.c and re-compiled GNU Emacs for X11. Then I tried to i-search ä, ö, ü etc in a test file in ISO 8859-1 encoding, which worked OK so I assumed it would work for 75 other characters too. So I opened (v in dired-mode) the ISO 8859-2 test file and tried to i-search again. It failed. And failed for all other ISO Latin-x test files, including ISO 8859-15, too.

The still running GNU Emacs from Tuesday has open in lisp-mode the file with the infamous 'ö', that can't be found. When I dired in exactly that same Emacs in dired-mode the directory with my test files and v the ISO 8859-1 test file I can isearch and find ö, to no surprise. In ISO 8859-2 test buffer it fails too to i-search °, §, ä ...

My test files are text files with a few columns and 100 or such lines. They have headers à la:

;;; -*- mode: Text; coding: iso-8859-2; -*-
;       Time-stamp: <2004-12-13 13:18:21 pete>
;   Central and Eastern European Glyphs (Latin 2)

The Lisp file, that defines fontsets, starts this way:

;;; -*- mode: Emacs-Lisp; coding: iso-8859-15; -*-
;       Time-stamp: <2005-04-12 23:30:39 root>
(message "Neue fontsets für Mac OS X")

So, to be exact: your patch does not solve my problem(s), could be it does not change anything. It still makes a difference whether Emacs reads something from a file or I input it from the keyboard. No unification here -- as in physics too.

There *is* one thing that makes a difference: when I launch Emacs from emacs/src without options or launch it from /usr/local/bin with option -Q, both have a rather big font or fontset on and both can search in an ISO 8859-15 buffer for ä, ö, ü -- and they find them! ISO 8859-2 shows success too. It it is obvious that there's something wrong in my customization that breaks it all!

Can you give me some pointers, please? Although I think that today I might not find time to check that all (someone's waiting).



There is no worse tyranny than to force a man to pay for what he does not want merely because you think it would be good for him. -- Robert Heinlein

reply via email to

[Prev in Thread] Current Thread [Next in Thread]