[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: generic-x mode does not load in init

From: Clemens Fischer
Subject: Re: generic-x mode does not load in init
Date: 26 May 2005 21:33:16 +0200
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (berkeley-unix)

* Eli Zaretskii:

>> From: Lute Kamstra <address@hidden>
>> Date: Wed, 25 May 2005 18:28:34 +0200
>> Cc: address@hidden
>> > i've had another problem with lisp/generic-x.el after "cvs up" today.  it
>> > wouldn't compile, because:
>> >
>> >   generic-x.el:462:11:Error: Symbol's function definition is void: 
>> > generic-make-keywords-list
>> The message you quote also contains my suggestion to use make
>> bootstrap, which solved the problem for Frederik.  Why don't you try
>> that too?

sorry, i forgot to mention that i always use the "bootstrap" target, because i
don't cvs all that often.  i'm running freebsd-5.4, btw.

> My crystal ball says that bootstrap is not required, just deleting
> lisp/generic.elc should be enough (it's a stale file that shadows
> lisp/emacs-lisp/generic.elc).

your crystal ball is amazing, but you should't trust it:

0 p1 $ ll lisp/generic* lisp/emacs-lisp/generic*
215372 -rw-r--r--  1 root  wheel  - 11891 12 Mai 15:23 
214386 -rw-r--r--  1 root  wheel  -  6720 25 Mai 13:47 
199833 -rw-r--r--  1 root  wheel  - 53320 25 Mai 15:21 lisp/generic-x.el
199394 -rw-r--r--  1 root  wheel  - 45310 25 Mai 13:39 lisp/generic-x.elc

cvs obviously took care of the stale file.  i have "up -PAdT -I Readme" in my
~/.cvsrc, with `-T' propably unneccessary (i'm no committer).

so i really needed that

  0 p1 $ g -A5 -- -ino: lisp/generic-x.el
  lisp/generic-x.el:;; -ino: 20050525-1330
  lisp/generic-x.el-(eval-when-compile (require 'generic))

line, n'est ce pas?  without it, the compile failed, with it it worked.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]