[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

"No fonts match" error in Carbon Emacs, OS X 10.4.1

From: Darin Franklin
Subject: "No fonts match" error in Carbon Emacs, OS X 10.4.1
Date: Sat, 2 Jul 2005 14:38:07 -0500

I am unable to get Carbon Emacs to run on OS X 10.4.1. I get this error when I try to start it:

$ /Applications/Emacs.app/Contents/MacOS/Emacs
No fonts match `-*-monaco-*-*-*-*-12-*-*-*-*-*-mac-roman'

I'm using the Carbon build of GNU Emacs on OS X 10.4.1. I have the 2005-05-19 build from http://bluebeard.org/software/ emacs_osx/, but have also tried other builds.

I tried bypassing the init files, but that didn't help.
$ /Applications/Emacs.app/Contents/MacOS/Emacs --no-init-file
No fonts match `-*-monaco-*-*-*-*-12-*-*-*-*-*-mac-roman'

I tried --debug-init, but that doesn't produce any extra output.
$ /Applications/Emacs.app/Contents/MacOS/Emacs --debug-init
No fonts match `-*-monaco-*-*-*-*-12-*-*-*-*-*-mac-roman'

I tried using this as my ~/.emacs file, but I get the same error.
  (set-default-font "-*-monaco-*-*-*-*-14-*-*-*-*-*-macroman-1")
(add-to-list 'default-frame-alist '(font . "-*-monaco-*-*-*-*-14-*- *-*-*-*-macroman-1"))

I tried this as my ~/.emacs file:
  (set-default-font "fontset-mac")
  (add-to-list 'default-frame-alist '(font . "fontset-mac"))

I tried specifying the font name on the command line.
$ /Applications/Emacs.app/Contents/MacOS/Emacs --font "-*-monaco-*-*- *-*-14-*-*-*-*-*-macroman-1"
No fonts match `-*-monaco-*-*-*-*-12-*-*-*-*-*-mac-roman'

I tried using a bogus font name, but Emacs just ignores it.
$ /Applications/Emacs.app/Contents/MacOS/Emacs --font "foobar"
No fonts match `-*-monaco-*-*-*-*-12-*-*-*-*-*-mac-roman'

I read the PROBLEMS file at /Applications/Emacs.app/Contents/ Resources/etc/PROBLEMS. It suggests to check the following files:
I have none of those, but I doubt they are relevant anyway, since this is Carbon and not X11.

If the Carbon build does not use X11, where does it locate the fonts? Why does it want this particular font name? How do I force it to use a different font on startup?

I see that the name is hardcoded, so maybe that answers my second question.
$ strings /Applications/Emacs.app/Contents/MacOS/Emacs | grep monaco

xfontsel shows that "-*-monaco-*-*-*-*-12-*-*-*-*-*-macroman-1" is a valid font name. Note that the encoding is "macroman", not "mac- roman". Could that be the problem?

Thanks for any suggestions you can provide.

Darin Franklin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]