[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot modify directory list GTK file dialog

From: Jan D.
Subject: Re: Cannot modify directory list GTK file dialog
Date: Sun, 18 Dec 2005 17:58:15 +0100
User-agent: Mozilla Thunderbird 1.0 (X11/20041206)

Stephen Berman wrote:

I haven't used the menu or tool bars to visit files before, but I just
tried it and visiting worked, but modifying the directory list under
"Browse for other folders" didn't work.  I started emacs -q and
clicked on the file icon in the toolbar or the corresponding menu bar
entry.  At first I was able to add a directory to the list, but when I
tried to remove it, an error message window popped up which said:
"Could not remove a bookmark Bookmark saving failed: Could not change file mode: waitpid() failed: No child processes" Then I tried to add another directory and this time it failed with the
same error message (except it said "Could not add a bookmark...").
Subseqently, even after starting emacs -q again, and even after
deleting ~/.gtk-bookmarks, no modification of the list has been
possible.  As a sanity check, I tried the same in Firefox, which uses
the same GTK dialog, and it worked fine there.  I don't know if it's
significant that, while testing the file dialog with emacs -q, I also
had an Emacs session with my initializations running (I first tried
the GTK file dialog there and found the same problems).

I can't reproduce it, with or without Gnome. Are you running Gnome? Can you check the permissions on your home directory and you .gtk-bookmarks?

I'll have to see what this operation actually does and where the error message realy means. It is somewhere in the GTK sources, it might take a while.

Stay tuned ...

   Jan D.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]