[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: loaddefs.el on Windows incomplete

From: Ralf Angeli
Subject: Re: loaddefs.el on Windows incomplete
Date: Mon, 26 Dec 2005 16:56:17 +0100

* Eli Zaretskii (2005-12-24) writes:

> I installed a change that should fix this problem for you.  Can you
> sync with the repository and see if autoloads now work even with MSYS
> munging of the command line?

Thanks for your efforts.  I did a fresh checkout into a new directory,
ran `configure ...' and while doing `mingw32-make bootstrap' the
following error occurred:

--8<---------------cut here---------------start------------->8---
"./../bin/emacs.exe" -batch --no-init-file --no-site-file --multibyte -l 
autoload \
        --eval '(setq find-file-hook nil find-file-suppress-same-file-warnings 
t)' \
        -f w32-batch-update-autoloads 
"D:/software/windows/unix/src/emacs-22.0.50-clean-build/lisp/loaddefs.el" . 
calc calendar emacs-lisp emulation eshell gnus international language mail mh-e 
net obsolete play progmodes term textmodes url

Wrong type argument: symbolp, 0
mingw32-make[1]: *** [autoloads] Error -1
mingw32-make[1]: Leaving directory 
mingw32-make: *** [bootstrap-gmake] Error 2
--8<---------------cut here---------------end--------------->8---

In order to get a backtrace I set `debug-on-error' to t via the --eval
statement above.  That means I edited lisp/makefile.w32-in
accordingly and ran `configure' again.  Interestingly the error did
not occur with this change.  I tried this both in the directory where
the make call failed with the original makefile.w32-in and in a
directory which had not seen a make call before.  Same results.

Then I tried to run `mingw32-make bootstrap' in a freshly checked out
and configured directory including the patch I proposed for
lisp/makefile.w32-in and got the same error as above.  Let-binding
`debug-on-error' to t made the error vanish again.  Now I don't really
know where to look for the cause of the error.

Anyway, in the directories where the build succeeded I did a `diff -u
loaddefs.el ldefs-boot.el' which showed no differences between the
files.  The build I did about a week ago (with the patch I proposed)
shows lots of differences between the files.  So I am not really sure
if loaddefs.el was generated correctly.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]