[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem running certain interactive programs in M-x shell in W32

From: Eduardo Ochs
Subject: Problem running certain interactive programs in M-x shell in W32
Date: Mon, 26 Dec 2005 18:49:26 -0300

Hello list,

I'm geting a weird behavior for some interactive programs in M-x shell
and comint buffers in Emacs for W32... for example, if I run lua.exe in
a `M-x shell' buffer, I get this; compare with the "correct" output

Wrong (comint in W32):

  > print(1+2)
  > <<here I type a ^D>>
  Lua 5.0.2  Copyright (C) 1994-2004 Tecgraf, PUC-Rio

  Process shell finished

Right (GNU systems, shell windows in W32, telnet buffers in W32 Emacs
connecting to GNU or *NIX systems):

  Lua 5.0.2  Copyright (C) 1994-2004 Tecgraf, PUC-Rio
  > print(1+2)
  > <<here I type a ^C>>


I have tried the following configurations:
Emacsen (with and without -q/-Q):
  * GNU Emacs (i386-mingw-nt5.0.2195) of 2005-12-18 on W2ONE
    (Lennart Borgman's build, from
  * GNU Emacs (i386-mingw-nt5.0.2195) of 2005-06-26 on NONIQPC
    (From http://nqmacs.sourceforge.net/)
Operating systems:
  * Debian GNU/Linux Sarge
  * M$-Windows 2000 (in Portuguese)
    * native shells: command.com/cmd.exe, 4NT (shareware from
    * telnet program: plink.exe, from the PuTTY package (option:
      "-telnet"); I used it to connect to an IBM thing running AIX
Lua (MIT-like license; I tried it because I use it a lot and I know
its source reasonably well; versions 5.0.2 and 5.1-beta):
  * Binaries for W$ downloaded from
    -> http://luaforge.net/projects/luasocket/
  * I compiled it from the source in all the other platforms.

By the way, I stumbled on that bug while I was trying to understand
why tramp was not working on that W$ box... My guess is that the
problem with tramp and this problem with the handling of prompts and
output in comint might be related, but I don't know enough about
tramp's innards to subtantiate this guess - and the debug output that
I was able to squeeze from tramp by using

    (setq tramp-verbose 10)
    (setq tramp-debug-buffer t)

was too short for a bug report... In a few words, if anyone is
curious: the default command-line telnet and ftp clients in W$ run
well in command.com/cmd.exe/4NT.exe windows (i.e., outside Emacs), but
they get stuck when run in M-x shell; and tramp always gives me "FATAL
ERROR: Network error: Connection refused".

  Edrx, a.k.a. Eduardo Ochs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]