[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Recursive copies in dired abort on first error

From: Sven Joachim
Subject: Re: Recursive copies in dired abort on first error
Date: Fri, 08 Sep 2006 19:45:39 +0200
User-agent: Thunderbird (X11/20060812)

Richard Stallman wrote:
    However, there's still no indication of failed copies in the
    echo area or the *Messages* buffer. :-(

Can you debug why not?  The cond at the end of dired-create-files is
supposed to call dired-log-summary, which should call message.  Please
debug the code in dired-create-files to see why this doesn't do that

If you put a (debug) call before this code

       (format "%s failed for %d of %d file%s"
                operation (length dired-create-files-failures) total
                (dired-plural-s total))

you can (1) see if it really gets there, and (2) look at the
value of dired-create-files-failures, which ought to contain
a list of the file names that had trouble.

(1) It really gets there;
(2) dired-create-files-failures is nil inside the debugger.

The reason is that the variable was still inconsistently spelled;
sometimes dired-create-file-failures and sometimes
dired-create-files-failures.  After I standardized them to
dired-create-files-failures, things worked as expected, displaying a
message with the number and the names of the failed files.  I tried to
copy /etc and /tmp recursively, and the message was:

Copy failed for 29 of 2 files--type ? for details
((tmp/ssh-IHYRJT1622/agent.1622 tmp/lost+found [... many more files ...]

Certainly the `29 of 2' looks a bit odd; I don't know what should be
done about that.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]