[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

html-mode and related modes cause 100% CPU usage

From: Alex Malinovich
Subject: html-mode and related modes cause 100% CPU usage
Date: Wed, 21 Feb 2007 18:28:36 -0800

Loading html-mode or any of the related modes (html-helper-mode, RoR-HTML 
(Ruby-on-Rails HTML), etc.) causes emacs to jump to 100% CPU usage. Killing the 
buffer does not fix the issue. A full restart of Emacs is necessary.

I tried to get a bit more info about what was going on by attaching strace to a 
running emacs process to see what happens. As soon as html-mode or a related 
mode is loaded, the console gets spammed with:

gettimeofday({1172110565, 45296}, NULL) = 0
gettimeofday({1172110565, 45424}, NULL) = 0
write(4, ";\0\5\0\216\t`\4\0\0\0\0\33\0K\0\320\2\17\0C\0\5\0/\0`"..., 72) = 72

I see the gettimeofday calls during normal operation, but the particular 
'write' seen above never changes once the loop starts. The string is identical 
for as far back as I can scroll. Unfortunately, I have no idea what it means 
and my skills with gdb are within spitting distance of atrocious. 
Unfortunately, that distance is on the Even Worse side of atrocious.

I have verified that this happens both in the GTK frontend as well as when 
running Emacs from the console with the -nw option. On the hunch that 
font-highlighting might be the culprit, I tried disabling global-font-lock but 
the error still occured.

In GNU Emacs (x86_64-pc-linux-gnu, GTK+ Version 2.8.20)
 of 2007-02-17 on nautilus, modified by Debian
 (Debian emacs-snapshot package, version 1:20070217-1)
X server distributor `The X.Org Foundation', version 11.0.70101000
configured using `configure  '--build' 'x86_64-linux-gnu' '--host' 
'x86_64-linux-gnu' '--prefix=/usr' '--sharedstatedir=/var/lib' 
'--libexecdir=/usr/lib' '--localstatedir=/var' '--infodir=/usr/share/info' 
'--mandir=/usr/share/man' '--with-pop=yes' 
 '--with-x=yes' '--with-x-toolkit=gtk' 'build_alias=x86_64-linux-gnu' 
'host_alias=x86_64-linux-gnu' 'CFLAGS=-DDEBIAN -DSITELOAD_PURESIZE_EXTRA=5000 
-g -O2''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Major mode: HTML

Minor modes in effect:
  semantic-idle-scheduler-mode: t
  tooltip-mode: t
  tool-bar-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  auto-compression-mode: t
  line-number-mode: t

Recent input:
<up> <up> <up> <up> <up> <up> <up> <up> <up> <up> <up> 
<up> <up> <up> <up> <up> <up> <up> <up> <up> <up> <up> 
<up> <up> <up> <up> <up> <up> <up> <up> <up> <up> <up> 
<up> <up> <up> <up> <up> <up> <up> C-x o C-x o <down> 
<down> <down> <down> <down> <down> <up> C-SPC C-e M-w 
C-x k <return> C-x o C-x k <return> C-x o C-x 0 C-x 
C-f j u n k f i l e <return> M-x h t m l - m o d e 
<return> M-x r e p o r t - e m <tab> <return>

Recent messages:
Loading eieio-opt...done
Mark set
(New file)
Loading sgml-mode...done
Loading semantic-html...done
Loading semantic-edit...done
Loading semanticdb-file...done
Mark set [3 times]

reply via email to

[Prev in Thread] Current Thread [Next in Thread]