[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot activate font-lock-mode

From: Stefan Monnier
Subject: Re: cannot activate font-lock-mode
Date: Thu, 31 May 2007 13:19:20 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.1.50 (gnu/linux)

>>> I had this in my local variables section:
>>> mode: font-lock
>>> font-lock-keywords: ("^\\S-.*:$")
>>> which worked in Emacs 21, but does not work any more in Emacs 22.  I
>>> solved the problem by writing instead:
>>> mode: font-lock
>>> font-lock-defaults: (("^\\S-.*:$"))
>> I must say that I don't know why this has changed.
>> Does the patch below fix your problem?

> No, nothing changed.  If I use font-lock-keywords I get the message:
>  "Toggling font-lock-mode off; better pass an explicit argument."

That looks correct: since font-lock is now enabled by default your "mode:
font-lock" might very well end up turning the mode OFF, and this is what the
message tells you.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]