[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: unicode-2 branch: ^O goes missing

From: Kenichi Handa
Subject: Re: unicode-2 branch: ^O goes missing
Date: Thu, 26 Jul 2007 20:39:21 +0900

In article <address@hidden>, Tom Rauchenwald <address@hidden> writes:

> To reproduce:
> Create an empty File.
> Do C-q C-o in it. A sequence that looks like ^O should appear.
> Save the File and kill the buffer.
> Open the file again. ^O is not there anymore.
> With emacs22 this works.

> Background is that i tried a elisp-program that parses color-sequences in 
> IRC, and tried to match ^O, but with the unicode-2 branch this doesn't work 
> anymore because the ^O goes missing somewhere.

^O is a locking shift code of ISO-2022, and iso-2022
detector of emacs-unicode-2 was too strong compared with
that of Emacs 22.  I've just installed a fix.

But, it is in general safer to specify a proper coding
system (in your case, iso-safe or no-conversion?) if you are
reading a file that contains some binary data (for instance
by let-binding coding-system-for-read).  Another way is to
let-bind inhibit-iso-escape-detection to t.

Kenichi Handa

reply via email to

[Prev in Thread] Current Thread [Next in Thread]