[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[BUG] italics run past where they should

From: Alejandro Colomar
Subject: [BUG] italics run past where they should
Date: Wed, 20 Jul 2022 16:58:34 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.0.2

Hi Branden,

I'm not sure if this is a groff(1) bug, or less(1), or who knows...

I've seen it sporadically, but when I tried to reproduce it, I didn't remember how I had triggered it, so I couldn't report it. Now I can consistently reproduce it.

I'd expect the issue to be in less(1), because of how I trigger it, but it's weird, because I can't reproduce it with mandoc and less, so I attribute it to groff(1) for the moment.

So, to trigger the bug, do the following potion:

# I reproduced it in clone(2), installed from my git tree,
# but I also reproduced it with the clone(2) from my system,
# which hapens to be manpages-dev 5.13-1, so it should be easily
# reproducible.

$ man clone

# Now have a look at the synopsis.
# You'll notice (or actually not notice) no weird formatting,
# because there isn't

# Then, within less(1), search for 'flags' with /flags


# This should change the underscoring of some words after the match.
# If you close and open again the man page,
# you'll see the good formatting again.

# If I run the following command, then I can't reproduce it,
# which is why I suspect that it's a problem in groff(1).

$ man -w clone | xargs mandoc | less

I'm running:
$ groff --version
GNU groff version 1.23.0.rc1.2366-0328



Alejandro Colomar

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]