[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: (SOLVED) tramp (2.0.36); /bin/ls: illegal option -- h

From: kaustuv
Subject: Re: (SOLVED) tramp (2.0.36); /bin/ls: illegal option -- h
Date: Wed, 5 Nov 2003 23:52:44 -0800

Kai Grossjohann wrote ("Re: tramp (2.0.36);   /bin/ls: illegal option -- h"):
>address@hidden writes:
>> I just tried to get remote listing by
>> /
>> And i got this bug.
>Hm.  I just checked that Tramp is not sending the -h option to ls.  So
>I'm guessing it comes from somewhere else.
The problems was this. I use ls-lisp

(require 'ls-lisp)
(setq ls-lisp-use-insert-directory-program nil  ; Should be nil by default
      ls-lisp-verbosity nil                     ; Show user-group information
      ls-lisp-dirs-first t)                     ; Dirs then files
(setq dired-listing-switches "-asihFq")         ; Pass on ls options

This works ok on linux machines but on SUNOS there
is no option like -h for ls. is
a sun machien leading to this problem. 

Sorry for the trouble,


>You ought to have a *tramp/foo* and also a *debug tramp/foo* buffer.
>Can you send them to me?  (Perhaps remove sensitive information.)
>If you don't have both of those buffers, (setq tramp-debug-buffer t)
>and invoke Tramp again.

 Residence:                Office:      
 Kaustuv,                  Kaustuv,
 668 College Avenue,       Sci. Computing & Computational Mathematics, 
 Palo Alto,                Gates Building 2B, Stanford University,          
 CA 94306                  CA 94305-9025,
 USA.                      USA.
                   Cell: (650) 804-6465            
                 Emails: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]