[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Upgrading Debian causing login-trouble with 2.0.28

From: Kjetil Kjernsmo
Subject: Upgrading Debian causing login-trouble with 2.0.28
Date: Sun, 16 Nov 2003 23:35:35 +0100
User-agent: KMail/1.5.4

Hello World!

Sorry for not lurking before posting, and possibly not RTFMing as 
thoroughly as I perhaps could. This problem just appeared, and due to 
some other unfortunate circumstances, I'm rather desparate. 

I've been using TRAMP for some time with the stable Debian Woody distro. 
The version in Woody was simply 20020218-2, which doesn't tell me a 
lot, but hopefully it tells you more... :-) I'm using emacs 20.7.2

I upgraded to sid a few weeks ago, and I thought I used TRAMP since 
then, but I guess I might not, because today, it didn't work as I was 
used to. The version of TRAMP in sid is 2.0.28-1. 
The usage syntax has apparently changed. Previously, I had things like 
/[su/pooh]/, that's what I used up to recently. The new syntax seems 

I used the old su method (which, if I've understood it correctly doesn't 
have anything to do with the current su method), because I hadn't set 
up passwordless login on the remote server. Now I have.  

On the surface, what happens is that I try to log in, it apparently 
does, but if I try to do something, like tab-completion, emacs "hangs". 
That is, nothing is happening there for a reasonable length of time, 
there are no characters in the buffer and the modeline is gone, further  
the scroll bars and menu bars doesn't respond to mouseclicks. 
However, I had a customization buffer open at one time, and if I hovered 
the mouse over the buttons in that buffer, they were highlighted (but 
did nothing when clicked on). 

One of the things that happened in the beginning was that it asked me 
the well-known question with the fingerprint. I found that strange, but 
tried scp2 instead, and it didn't ask. Now, it doesn't ask about that 
anymore regardless of what version I'm using. Don't really understand 

Well, I try to edit a file as my own user on a remote host called pooh, 
this is the content of the *debug tramp/nil pooh* buffer:

# Opening connection at pooh using nil...
# Waiting for prompts from remote shell
# Waiting 60s for prompt from remote shell

And this is the content of the  *tramp/nil pooh* buffer:
Linux pooh #1 Mon Sep 29 14:00:55 CEST 2003 
i686 unknown unknown GNU/Linux
Last login: Sun Nov 16 22:21:35 2003 from
 [1;address@hidden:~> [0m 

So... I'm logged in OK... if I continue in the minibuffer to find a 
file, for example trying a tab completion, emacs "hangs" like described 
above. This also happens if I try to find a local file using 

However, my prompt looks slightly weird there, huh? :-) 
It's set in my .bashrc to:
PS1='\[\033[1;address@hidden:\w>\[\033[0m\] '
that's to get some neat colors and stuff... :-) 
I tried to set shell-prompt-pattern (because I use this on all hosts 
(yellow for user accounts, red for root accounts)) and 
tramp-shell-prompt-pattern, but it wasn't very successful... Nothing 
changed... Besides, this wasn't a problem with the older TRAMP (at 
least, it never bothered me). So I guess this might not be it. 

In the interest of bandwidth conservation, I didn't send or attach the 
data from the bug report, instead dumped it on my website:
I guess it may not be relevant any of it, it's more of a simple 
configuration issue, I guess... 

But the question is what? Any insights you can provide would be greatly 


Kjetil Kjernsmo
Astrophysicist/IT Consultant/Skeptic/Ski-orienteer/Orienteer/Mountaineer
address@hidden  address@hidden  address@hidden
Homepage:        OpenPGP KeyID: 6A6A0BBC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]