[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: efs + tramp + emacs problem.

From: Peter Valdemar Mørch
Subject: Re: efs + tramp + emacs problem.
Date: Sat, 03 Jan 2004 00:27:12 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031013 Thunderbird/0.3

Uhhm. I have very similar symptoms under Xemacs, but the aren't solved by the "Emacs expects /[ssh/address@hidden/ as Tramp syntax." suggestion. With the /ssh: syntax it tries FTP. With /[ssh it opens a buffer [ssh<yadayada> under /.

in *scratch* I tried
(find-file "/[ssh/address@hidden/etc/passwd")C-x C-e

The minibuffer says:
File not found and directory is write protected.
And then it opens a buffer called
under /

Any ideas what to try next? I did try both xemacs -vanilla and -no-init-file just to be sure. And then I tried the latest 2.0.38...

I really do prefer xemacs, so I'll try to stick with that...

XEmacs version from Help/about: [version 21.4; April 2001]
(tramp-version 1) 2.0.38

This is on a pretty fresh RedHat9 installation.
So something is weird.

I have *exactly* the same (describe-variable 'file-name-handler-alist) as Alex Koval, the original poster: Value: (("^/\\([[][^]]*\\)?$" . tramp-completion-file-name-handler) ("^/[^/:]+:" . efs-file-handler-function) ("^/$" . efs-root-handler-function) ("\\`/\\[.*\\]" . tramp-file-name-handler) ("\\(^\\|[^$]\\)\\(\\$\\$\\)*\\$[{a-zA-Z0-9]" . efs-sifn-handler-function))

BTW, there was a previous version 2.0.22 install (born with RH9), but I did download, configure, make and then:

(add-to-list 'load-path "~/work/tramp/lisp/")
(add-to-list 'load-path "~/work/tramp/contrib/")
(require 'tramp) <<-- Shows 2.0.38
(find-file "/[ssh/address@hidden/etc/passwd")

reply via email to

[Prev in Thread] Current Thread [Next in Thread]