[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: login fails

From: Haines Brown
Subject: Re: login fails
Date: Thu, 24 Feb 2005 07:32:37 -0500 (EST)

> > I'm running debian sarge, emacs 21.3.1, and am attempting to set up
> > tramp. I'm currently using gFTP and can also access the host from a
> > command line FTP command.
> >
> > In ~./emacs I have:
> >
> >   (add-to-list 'load-path "/usr/share/emacs/site-lisp/tramp/")
> >   (require 'tramp)
> >   (setq tramp-default-method "ssh")
> Oops. Surprisingly, you enter the "ftp" method ...
> > And I do:
> >
> >   C-x C-f /address@hidden:/html]
> >   ftp> open
> >   Connected to
> >   220 customer NcFTPd Server (licensed copy) ready.
> >   user "[USR1066" Turtle Power!
> Here we are. Tramp regards "[USR1066" as your user name. Please try
> the following syntax: "C-x C-f /address@hidden:/html". If
> it goes via "ssh", you should apply "C-x C-f
> /ftp:address@hidden:/html".

Interesting. The [] at least allowed an attempted log in, but with
incorrect username of "[USR1066". When I remove the brackets, I don't
even get that.

I gather that if I want to ftp without ssh, I should use the syntax:

  C-x C-f /address@hidden:/html

This simply causes emacs to move into the tex mode, opening a html
document template! I tried to reduce ":/html" to just ":/", and emacs
instead now offers to create the directory

I do wish to use ssh, and so tried:

  C-x C-f /ftp:address@hidden:/html

and emacs simply wants again to create the directory.

I couldn't make head or tail of the tramp manual page on this issue. 

Haines Brown

reply via email to

[Prev in Thread] Current Thread [Next in Thread]