[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: login fails

From: Haines Brown
Subject: Re: login fails
Date: Fri, 25 Feb 2005 15:06:39 -0500 (EST)

I was able to get to my target disk today and look into why ssh is not
successfully logging into an ftp server. I checked that ssh was fully
installed and was configured.

You suggested that I run ssh from a command line, that worked very
nicely. I could not reproduce the problem using that method. Here are
bits of the session:

  $ ssh -vvv address@hidden:/html
  OpenSSH_3.8.1p1 Debian-8.sarge.4, OpenSSL 0.9.7e 25 Oct 2004
  debug1: Checking 
  debug1: Reading configuration data /etc/ssh/ssh_config
  debug2: ssh_connect: needpriv 0
  debug1: Connecting to [] port 22.
  debug1: Connection established.
  debug1: Enabling compatibility mode for protocol 2.0
  debug3: check_host_in_hostfile: filename /home/brownh/.ssh/known_hosts
  debug3: check_host_in_hostfile: match line 1
  debug1: Host '' is known and matches the RSA host key.
  debug1: Found key in /home/brownh/.ssh/known_hosts:1
  debug1: Authentications that can continue: publickey,password
  debug3: remaining preferred: ,password
  debug3: authmethod_is_enabled password
  debug1: Next authentication method: password
  address@hidden's password: 
  debug3: packet_send2: adding 64 (len 57 padlen 7 extra_pad 64)
  debug2: we sent a password packet, wait for reply
  debug1: Authentication succeeded (password).
  debug1: channel 0: new [client-session]
  debug3: ssh_session2_open: channel_new: 0
  debug2: channel 0: send open
  debug1: Entering interactive session.
  debug2: callback start
  debug2: ssh_session2_setup: id 0
  debug2: channel 0: request pty-req
  debug3: tty_make_modes: ospeed 38400
  debug2: callback done
  debug2: channel 0: open confirm rwindow 0 rmax 32768
  debug2: channel 0: rcvd adjust 131072
  Last login: Fri Feb 25 13:58:10 2005 from

So ssh is working, but I'm nevertheless having trouble with trap using
ssh in emacs. When I do simple ftp, I've no problem. These give me
access to the files on the server:

  C-x C-f /ftp:address@hidden:/html
  C-x C-f /address@hidden:/html

But both of the following commands fail (I have ssh set as default in

  C-x C-f /address@hidden:/html
  C-x C-f /ssh:address@hidden:/html

Both return: 

  File not found and directory is write protected

There is nothing in /var/log/auth.log of interest.

My question: 

Does the ssh debug result suggest that there's no problem with ssh,
and that I need instead to look at what tramp is doing when using ssh?

When I use tramp under emacs to access the file server, the
handshaking appears normal, but eventually fails with the above error
message. Does it suggest that under ssh I'm simply trying to log in
where I am not allowed?

If I truncate the target and use simply:
   C-x C-f /address@hidden
I get put into what appears to be the file server's root
directory. This suggests to me that my syntax ( is not
putting me in the right place, although the syntax looks correct. Is
this inference correct? 

Haines Brown 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]