[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: login fails

From: Michael Albinus
Subject: Re: login fails
Date: Sat, 26 Feb 2005 11:20:36 +0100
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/22.0.50 (gnu/linux)

address@hidden (Haines Brown) writes:

> I was able to get to my target disk today and look into why ssh is not
> successfully logging into an ftp server. I checked that ssh was fully
> installed and was configured.
> You suggested that I run ssh from a command line, that worked very
> nicely. I could not reproduce the problem using that method. Here are
> bits of the session:
>   $ ssh -vvv address@hidden:/html

Are you really sure you have done it this way? ssh does not accept
path names in host names. Here my local attempt:

magdalene:~/src/emacs> ssh -vvv address@hidden:/html
OpenSSH_3.8.1p1 Debian-8.sarge.4, OpenSSL 0.9.7e 25 Oct 2004
debug1: Reading configuration data /home/albinus/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug2: ssh_connect: needpriv 0
ssh: Name or service not known

When I apply "ssh -vvv address@hidden", I reach a password
prompt (which I'm not able to awnser, of course).

> So ssh is working, but I'm nevertheless having trouble with trap using
> ssh in emacs. When I do simple ftp, I've no problem. These give me
> access to the files on the server:
>   C-x C-f /ftp:address@hidden:/html
>   C-x C-f /address@hidden:/html
> But both of the following commands fail (I have ssh set as default in
> ~/.emacs): 
>   C-x C-f /address@hidden:/html
>   C-x C-f /ssh:address@hidden:/html
> Both return: 
>   File not found and directory is write protected

ftp and ssh use different root directories. Please try the following:

  C-x C-f /ssh:address@hidden:/
  C-x C-f /ftp:address@hidden:/

Both cases, you will be in dired, showing directory listing of
respective root diectories.

> If I truncate the target and use simply:
>    C-x C-f /address@hidden

I assume you mean "/address@hidden:". Sorry for being
pedantic, but it makes a difference.

> I get put into what appears to be the file server's root
> directory. This suggests to me that my syntax ( is not
> putting me in the right place, although the syntax looks correct. Is
> this inference correct? 

"/address@hidden:" should show the home directory of
usr1066. "/address@hidden:/" goes to the root directory of
the host (ssh method assumed). Both directories are different to the
ftp root directory.

Sorry for confusing you, but all these things are outside Tramp's

> Haines Brown 

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]