[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: login fails

From: Haines Brown
Subject: Re: login fails
Date: Sat, 26 Feb 2005 14:47:08 -0500 (EST)

> >   $ ssh -vvv address@hidden:/html
> Are you really sure you have done it this way? ssh does not accept
> path names in host names. Here my local attempt:

I went back and tried it again, and indeed it didn't work. I apologize
for bumbling somewhere along the line.

> ftp and ssh use different root directories. Please try the following:
>   C-x C-f /ssh:address@hidden:/
>   C-x C-f /ftp:address@hidden:/

That was news to me, and indeed led me to the solution. The following
works splendidly:

   C-x C-f /address@hidden:

Thanks for the patience of one and all! 

Only one strange thing. I find I can access everyone else's account to
the extent I have read permission for their files! Surely this is not
right. Or is it? While I lack permission to do mischief, I certainly
can snoop.

Having managed to use tramp via ssh to access my own account, I'm then
faced with certain configuration challenges. I hesitate to impose more
newbie questions, but people have been very forbearing up to
now. After half a day struggling with the manual and man ssh_config,
I'm left with the following issues.

A) Pickling the password cache

To make the password cache permanent rather than expire when the emacs
session ends, I gather I should use:

  password-cache-expiry nil

I haven't a clue where to put this. Among other experiments, I tried
to put into /.emacs 

  (setq password-cache-expiry nil) 

but it had no effect.

B) Adding a directory to the hostname

I gather that to append a directory rather than text file to the target
host address, I need to have in /.emacs the following:

  (add-to-list 'tramp-remote-path "/usr/local/perl/bin")

If I then proceed to do

  C-x C-f /address@hidden:/html

I get the old error that the file is not found. Without the appended
directory, the directory I do access has the html subdirectory. I also
get the error: 

  Wrong type argument: integerp, nil

C) I'd like to set up an alias so that I don't have to type in the
entire "address@hidden:" each time. So I tried in
/etc/ssh/ssh_config to add a stanza before the system wide default
stanza, such as this:


It seems I can alias the hostname by adding the line:

  HostName test

But I'm clearly on the wrong track:

  C-x C-f /test:

  ssh: test: name or service not known

What I'd like to do is to run a command such as:

  C-x C-f /interland

And have it take me to address@hidden: I did my best to
figure out the ssg-config manual, but obviously failed miserably.

Haines Brown

reply via email to

[Prev in Thread] Current Thread [Next in Thread]