[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

format-spec problem with tramp?

From: Lei Tang
Subject: format-spec problem with tramp?
Date: Sat, 23 Sep 2006 16:10:33 -0700
User-agent: Mozilla Thunderbird 1.0.6 (Windows/20050716)

This is a Xemacs21.4.19 user under windows XP (without Cgywin). I just installed tramp 1.32 through Xemacs menu. However, when I use C-x C-f to access some file from the sever in our school, I encountered some error like:
"Can not open load file: format-spec".

After searching the Internet for some solution, I found someone who tried to configure tramp with native Xemacs in windows Xp (See the slides there :

So I just copied the configuration to my init.el as follows:

(setq exec-path (append exec-path '("D:\\XEmacs\\PuTTY\\")))
; I put the free putty.exe under dir "d:\XEmacs\PuTTy"
(require 'tramp)
(setq tramp-default-method 'plink')
(setq tramp-password-end-of-line "\r\n")
(setq shell-prompt-pattern "^.*%")  ;

However, when I start Xemacs, still the same error like below:

(1) (initialization/error) An error has occurred while loading d:\Lei\Configration\.xemacs\init.el:

Cannot open load file: format-spec

To ensure normal operation, you should investigate the cause of the error
in your initialization file and remove it.  Use the `-debug-init' option
to XEmacs to view a complete error backtrace.

Can any body tell me what is wrong?

I really appreciate it if anyone can give me some hint about the configuration command:
(setq shell-prompt-pattern "^.*%")

Do I have to change the pattern according to the sever I am gonna to connect?

Besides, how to view the backtrace of XEmacs? Use the `-debug-init' option? How to specify the option?

Too many questions. I feel all the manuals of packages seems pale when there's something wrong.

Thanks a lot!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]