[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Find-file problem when connecting from Windows box with plink

From: Michael Albinus
Subject: Re: Find-file problem when connecting from Windows box with plink
Date: Wed, 31 Jan 2007 21:27:32 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/22.0.93 (gnu/linux)

Jyrki Jaakkola <address@hidden> writes:

> Hello!


> I'm using tramp 2.1.8 and Emacs 21.3.1 (although I have tested this
> also on latest ntemacs [ntemacs22-bin-20070102]). I'm running emacs on
> WinXP box. I'm using plink (from Putty 0.59) to connect to my linux
> box. If I do C-x C-f /plink:address@hidden:/home/foo/existing-file
> from for example slime repl the file opens without a hitch. When I use
> find-file to provide file list on specific folder and then try to
> select a file I get an error "Wrong type argument: stringp, nil". Also
> if I try to use C-x C-f on same buffer I get the same error. Here is
> the backtrace for the situation:
> Debugger entered--Lisp error: (wrong-type-argument stringp nil)
>   intern(nil [0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0])
>   vc-file-clearprops(nil)
>   vc-file-not-found-hook()
>   run-hook-with-args-until-success(vc-file-not-found-hook)
>   byte-code("unreadable" [filename buf error file-exists-p 
> file-readable-p kill-buffer signal file-error "File is not readable"
> run-hook-with-args-until-success find-file-not-found-hooks t] 4)
>   find-file-noselect-1(#<buffer file.lisp>
> "/plink:address@hidden:/home/foo/file.lisp" nil nil
> "/plink:address@hidden:/home/foo/file.lisp" (149209 (-1 0)))
>   find-file-noselect("/plink:address@hidden:/home/foo/file.lisp"
> nil nil nil)
>   find-file("/plink:address@hidden:/home/foo/file.lisp")
>   dired-advertised-find-file()
>   call-interactively(dired-advertised-find-file)

I couldn't catch it completely. Looks like the file on your remote
system is under version control - right? Could you, please, rerun the
test with deactivated vc? You could do this by

(setq vc-handled-backends nil)

> I have looked to tramp debug output but there doesn't seem to be
> anything out of order but if you need the debug output I can provide
> that. When I tried doing same from a linux box with ssh I could use
> find-file without a problem. As I couldn't test plink on linux box I'm
> not sure how it would behave.

A Tramp debug buffer is always valuable. Maybe you could provide it;
setting tramp-verbose to 6 shall be sufficient.

> Jyrki Jaakkola

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]