[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp and FreeBSD

From: Rommel Martinez
Subject: Re: Tramp and FreeBSD
Date: Mon, 18 Feb 2008 19:50:20 +0800

On Feb 18, 2008 6:02 PM, Michael Albinus <address@hidden> wrote:
> "Rommel Martinez" <address@hidden> writes:
> > ssh host -l user -e none
> >
> > Lets me login with no output other than the prompt.
> OK. However, I'ld like to see all the output during the login
> procedure; maybe there is something which hinders Tramp from proper work.
> If you don't want to make it public, please send it to me off the list.
> Best regards, Michael.

I'm using Zsh both on my local machine and the remote machine
(It doesn't matter which shell I use for the local machine anyway, right?).

I've tried changing shell on the remote account. I've tried changing it to
Csh, Bash, and Sh. I then Tramp'd to the remote server, and it
worked, all except Zsh.

Since Zsh is the most likely culprit, with the possibility that the prompt
may be involved too, I temporarily renamed my Zsh init files on the
remote server (.zshenv and .zshenv).

There are no global Zsh init files in the remote server. The default prompt
for Zsh (as of v4.3.2_1) is:


which would yield to the following if the FQDN is


(if non-root user)


(if root user)

I suspect what's causing the problem is the prompt. I'll have to talk
to the sysadmin tomorrow and request that the default Zsh prompt
be changed to something else, say "$ ", for the timebeing.

I'll post updates.

Rommel M. Martinez <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]