[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.2.3-24.1); Using tramp to run ess-remote session. Submittin

From: Michael Albinus
Subject: Re: tramp (2.2.3-24.1); Using tramp to run ess-remote session. Submitting more than one line of code at a time, causes emacs to wait indefinitely.
Date: Fri, 08 Feb 2013 16:55:37 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

Tobias Muhlhofer <address@hidden> writes:

[Cc address@hidden, for the archives]

> Michael:

Hi Tobias,

> First, thank you for the quick reply.
> Your test setup seems appropriate to me. As for versions, I'm using
> ESS 12.09 (which seems to be their latest and happens to ship with
> Fedora, which I use). I have tried this on three different remote
> servers with slightly different setups and have still run into the
> same issue.
> For whatever it's worth, I didn't have this problem, last time I used
> this procedure (which was several months ago). Of course, in the
> meantime there are probably new versions of just about everything,
> including Tramp, but also Emacs and ESS which I realize makes things
> difficult to track down.
> One more thing; a similar phenomenon appears in the following situation.
> 1) Use Tramp to open a remote R file for editing (i.e. C-x C-f
> /<username>@<server>:/<path-to-file>).
> 2) Start an R session with M-x R. In that case the newest default
> behavior is to want to start the R session on the remote machine (by
> suggesting a tramp remote starting directory there). Do that.
> 3) You get asked for your password.
> 4) Spinning "Emacs waiting" icon appears and never goes away. Maybe
> Tramp managed to log in, started R, and tried to feed some code. Maybe
> something else, though.
> Let me know if this is an ESS problem, and I will be happy to report
> this over there.
> I also looked at the link you referenced. If I undestand correctly
> ANSI-term is what creates colors in a terminal session? If it helps,
> there are no problems with doing "ls" somewhere in the normal shell
> (i.e. outside of R) on the remote server. I mean, no colors will
> appear, but there are no tie-ups. Maybe what I just said shows my lack
> of understanding of the issue referenced there, but I figured I'd try
> anyway... ;-p

At home, I have a Fedore 18 equipped machine. When time permits, I'll
play with it over the weekend.

> Thanks for the help!
>    Toby

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]