[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Connect to the ssh and execute any command

From: Michael Albinus
Subject: Re: Connect to the ssh and execute any command
Date: Fri, 04 Oct 2013 17:50:32 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

Andrey Tykhonov <address@hidden> writes:

> Hi Michael!

Hi Andrey,

> I just recently get a chance to test these changes.
> I cloned git:// git repository to the 
> ~/.emacs.d/tramp/ and added 
> (add-to-list 'load-path "~/.emacs.d/tramp/lisp/")
> and 
> (setq tramp-verbose 6)
> on top of my .emacs.

I hope you did also "autoconf; ./configure". This is needed in order to
get a proper tramp-loaddefs.el file.

> I tried again:
> cd /ssh:address@hidden:/var/log/
> And then "ls -la". I'm not getting error as before but in each folder
> where I made "ls -la" instead of file list I get "total 0":
> /ssh:address@hidden:/var/log $ ls -la
> total 0
> But indeed there are files.

Sorry, I'm a little bit lost. How have you performed "cd
/ssh:address@hidden:/var/log/"? In an eshell buffer? 

> Then I tried:
> C-x C-f
> and I can change folders but when I open some file I get:
> Tramp: Inserting
> `/ssh:address@hidden:/some/path/'...failed
> File exists, but cannot be read
> I suppose that that gonna be a hard task to make tramp workable in my
> case. This seems require a lot of debugging and tracing all code and
> check step by step where there are issues and then fix them.

Let's see, how far we go. Keep tramp-verbose 6. Everytime, a command
fails, tell me exactly what you have done (I must go the same steps),
and show mw the whole Tramp debug buffer.

> Anyway, thank you very much Michael!
> Best regards,
> Andrey

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]