[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with Windows

From: Vilibald
Subject: Re: Problem with Windows
Date: Mon, 04 Aug 2014 20:20:39 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

I had to work from Windows too and had the same setup as you do and encountered same error. The cause was the shell prompt which tramp didn't recognize.
My way to fix it was to set the tramp-terminal type to "dumb"

M-x customize-variable RET  tramp-terminal-type

and in the .bashrc file check for it and set the the prompt correctly along these lines

case "$TERM" in
    PS1="> "
    # PS1="my prompt > "
    PS1="> "

Other option is to customize the variable tramp-terminal-prompt-regexp but that caused me more headache.


On 08/04/2014 04:08 PM, Tobias Bora wrote:

I usually use Emacs under Linux, but I need to configure Emacs on a Windows
machine. Everything work fine except the tramp connection: I would like to
connect to a linux computer by ssh, so I run:


And then C-j (or enter, same problem), I'm prompted to give my password,
but after nothing happened, the following message is displayed until I
press C-g:
"Tramp: Waiting for prompts from the shell"

The same problem occurs on my two computers, do you know how I could solve
it ?

Thank you,


Tramp-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]