[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with tramp and magit

From: Stephan Lindner
Subject: Problem with tramp and magit
Date: Thu, 21 Jun 2018 11:00:32 -0700
User-agent: mu4e 1.1.0; emacs 24.5.1

Hi there,

I cannot use magit when accessing a project on my server via tramp.  I think 
this is a question that was asked before
 but I could not
find a solution.

Here is the warning message:

|  Error (magit): Magit requires Git >= 1.9.4, but on /ssh:address@hidden: the 
version is 1.8.3.
|  If multiple Git versions are installed on the host then the
|  problem might be that TRAMP uses the wrong executable.
|  First check the value of `magit-git-executable'.  Its value is
|  used when running git locally as well as when running it on a
|  remote host.  The default value is "git", except on Windows
|  where an absolute path is used for performance reasons.
|  If the value already is just "git" but TRAMP never-the-less
|  doesn't use the correct executable, then consult the info node
|  `(tramp)Remote programs'.

I checked in with an admin person who told me that there are different versions 
of git on the server.  So I created a
symlink in my home bin director (/home/users/lindners/bin) to a different git 

|  address@hidden bin]$ ls -lh        
|  lrwxrwxrwx. 1 lindners HPCUsers 33 May 29 15:00 git -> 

And when I check the version I get this:

|  address@hidden bin]$ git --version
|  git version 2.9.3

I further added the path to tramp-remote-path:

|  (add-to-list 'tramp-remote-path "/home/users/lindners/bin")

But the problem still persists.  If there a solution to this issue?

Thanks so much!  I am using tramp daily and it is great! 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]