[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; Copy-paste of folder from Windows machine to Lin

From: Guillaume Demeyère
Subject: Re: tramp (; Copy-paste of folder from Windows machine to Linux server does not work
Date: Tue, 9 Jul 2019 13:42:31 +0200

Hi Michael,

Thank you for your analysis!

I re-ran the test "copy-file" with emacs -Q beginning with setting tramp-verbose to 6. The logs are attached.

I only use 7zip to compress/decompress archives on this MS-Windows.


Guillaume Demeyère

Michael Albinus <address@hidden> escreveu no dia terça, 9/07/2019 à(s) 10:33:
Guillaume Demeyère <address@hidden> writes:

> Hello Bruno, and thank you for your answer!

Hi Guillaume,

> Here's what I'm trying to do. I just re-ran those tests with emacs -Q
> to make sure it's not my Emacs configuration that creates the issue.
> 1 - I open a dired view on my Windows machine, on folder
> ‘c:/Users/gde3/Documents/scratch/BTWW-Widgets-4-3DSpace-master/Widgets/UM5GraphVue/scripts
> 2 - I type "C" to copy the file 'Main.js’ to my Linux server, with the
> following path:
> ‘/plink:nxuser@vdemopro892dsy|su:root@vdemopro892dsy:/home/data/RTV/DEMOR421/apache-tomcat/webapps/3DSpace/webapps/UM5GraphVue/scripts/’
> 3 - The transfer fails with the following error :
> Copy
> ‘c:/Users/gde3/Documents/scratch/BTWW-Widgets-4-3DSpace-master/Widgets/UM5GraphVue/scripts/Main.js’
> to
> ‘/plink:nxuser@vdemopro892dsy|su:root@vdemopro892dsy:/home/data/RTV/DEMOR421/apache-tomcat/webapps/3DSpace/webapps/UM5GraphVue/scripts/Main.js’
> failed:
> (file-error Couldn’t write region to
> ‘/plink:nxuser@vdemopro892dsy|su:root@vdemopro892dsy:/home/data/RTV/DEMOR421/apache-tomcat/webapps/3DSpace/webapps/UM5GraphVue/scripts/Main.js’,
> decode using ‘(base64 -d -i | env GZIP= gzip -d >%s)’ failed)
> Even more simple test : running M-x copy-file from first directory to
> distant directory fails with the same error.

Thanks! Could you pls add next time the debug buffer as attachment?
This would avoid line breaks by your (or mine) mail program, and it
would ease the analysis.

> I re-run these tests after setting tramp-verbose to 6. Here are the
> logs I get:

> ;; Emacs: 26.2 Tramp: -*- mode: outline; -*-
> 08:41:47.154224 tramp-send-command (6) # echo are you awake
> 08:41:47.206419 tramp-wait-for-regexp (6) #
> are you awake

That means the debug buffer does not include the hand-shaking, and the
analysis Tramp performs on the local and remote host. Usually we don't
need this, but in your case it is relevant. Next time I need a debug
buffer after you have started Emacs from scratch, and have run the
(failed) test case.

> 08:41:49.224909 tramp-call-process-region (6) # ‘env GZIP= gzip’ 1 61018 t  *temp*
> 08:41:49.281511 tramp-call-process-region (6) # 0
> 08:41:49.293791 tramp-send-command (6) # (base64 -d -i | env GZIP= gzip -d >/home/data/RTV/DEMOR421/apache-tomcat/webapps/3DSpace/webapps/UM5GraphVue/scripts/Main.js) <<'24c41d6fdb57a2d9d7589c2bb1c1d2f8'
> 24c41d6fdb57a2d9d7589c2bb1c1d2f8
> 08:41:49.386003 tramp-wait-for-regexp (6) #
> gzip: stdin: not in gzip format
> ///45900a6002f51917e1043ba41f5a5af3#$

That means that Tramp has decided to use a *local* gzip program for
compressing / decompressing. Do you have something like this on your
Windows machine?

And that's why I like to see the initial hand-shaking, because during
that time Tramp decides what to use, locally and remote. Pls use "emacs
-Q" for that test, it refuses any cached data.

> N.B. : I checked that I could create files and directories on my Linux
> server, and that base64 worked on it, by running base64 -d <<<
> QWxhZGRpbjpvcGVuIHNlc2FtZQ==
> And it worked.

Sure. That's not the problem.

> Guillaume Demeyère

Best regards, Michael.

Attachment: 2019-07-09TrampDebugLog
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]