[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp hangs

From: Mark Geary
Subject: Re: tramp hangs
Date: Wed, 18 Sep 2019 16:30:43 -0400 (EDT)
User-agent: Alpine 2.21.99999 (BSF 352 2019-06-22)

On Wed, 18 Sep 2019, Michael Albinus wrote:

Mark Geary <address@hidden> writes:

Hi Mark,

I'm trying to use tramp to edit a file on a Solaris 11 box.

Uhh, Solaris is always problematic.

This worked until a year (very approximately) ago. I can't think of
anything that changed at the time it stopped working. I'm fairly
certain that the upgrade from Solaris 10 to 11 did not coincide with
the onset of the tramp problems.

I run "emacs -q" and set tramp-verbose to 6

That's good. But please always send Tramp traces as attachment. Mailers
change line folding, and the traces become almost unreadable.

When I try to open .profile on sfmg10, I see this in the mini-buffer area:

Tramp: Opening connection for sfmg10 using ssh...done
Tramp: Inserting '/ssh:sfmg10:/home/mag43/.profile'...failed

Emacs then hangs. I interrupt it with C-g.
The tramp debug buffer follows:

Here we find:

17:09:23.769961 tramp-send-command (6) # ( (test -e
/home/mag43/.profile || test -h /home/mag43/.profile) && (env
QUOTING_STYLE=locale /usr/ccs/bin/stat -c '((/////%N/////) %h %u %g %X
%Y %Z %s /////%A///// t %i -1)' /home/mag43/.profile | sed -e
's/"/\\"/g' -e 's/\/\/\/\/\//"/g') || echo nil) 2>/dev/null; echo
tramp_exit_status $?

17:09:23.780967 tramp-wait-for-regexp (6) # bash: dev/null: No such
file or directory
tramp_exit_status 127

What's up with /dev/null on that remote host? Note, that Tramp has
decided to use /usr/ccs/bin/bash there, for whatever reason.

Thanks for looking at this.

/usr/ccs/bin is a link to /usr/bin.

Looking more closely, I notice that the "/" before "dev" happens to be
the 256th character of that line. I'm sure that's no coincidence, but
I can't figure where the limit comes from or what, exactly, is being

If I open a new window and copy-paste lines from the invocation of
bash up to the one before this one (the readlink), then break this
line (after the "&&", for example) into two lines, the stat succeeds.

Alternately, if I put an empty string for the TERM type in the bash
invocation and leave out the "set +o emacs" further down ("set +o vi"
is ok) then I can paste the entire 292-character "stat" line and get
the proper output.

I am unsure of the best direction to proceed from here. Add one of the
above work-arounds in Tramp? (How?) Further digging to find the root cause?


Fifty-four Forty or Fight!

Attachment: sfmg10-tramp-debug
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]