[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp no longer connects to aws instances

From: Michael Albinus
Subject: Re: Tramp no longer connects to aws instances
Date: Sat, 26 Oct 2019 16:49:28 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Frederick Bartlett <address@hidden> writes:

Hi Fred,

> I did have the host in my ~/.ssh/config file -- with the wrong ip
> address and the wrong path to the key. (Nevertheless, Tramp had worked
> for years ....)
> So I fixed that, and can now connect from the command line via ssh
> <foo>, as one would expect (I had been using an aliased command).


> However, Tramp works only if I supply the username in the connect
> string: (find-file "/ssh:<user>@<foo>:/home/<user>/<file>" t)
> If I don't, it uses a wrong name from 'tramp-default-user-alist, and
> the connection fails.

How does your tramp-default-user-alist look like?

> Even if I remove that name from .emacs and reload, Tramp still uses
> that name, so it must be getting it from elsewhere -- it's not my
> local machine username, but the name that goes with an entirely
> different remote server.

Apply "M-x tramp-cleanup-all-connections". If there's still the same
problem, call a new Emacs session via "emacs -Q". Visiting "/ssh:foo:"
shall work there.

Start to bisect your init file(s) (~/.emacs, at least), in order to
find which part of it causes the trouble.

> Thanks!
> Fred

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]