bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Miscellaneous code readability improvements.


From: Akim Demaille
Subject: Re: [PATCH] Miscellaneous code readability improvements.
Date: Thu, 13 Aug 2009 11:44:18 +0200


Le 13 août 09 à 10:02, Joel E. Denny a écrit :

  \\(.|\n)      {
- complain_at (*loc, _("unrecognized escape sequence: %s"), quote (yytext)); + complain_at (*loc, _("unrecognized escape sequence: `%s'"), yytext);
    STRING_GROW;
  }

I think it should be

+ complain_at (*loc, _("unrecognized escape sequence: `\\%s'"), yytext + 1);

to cope with \ followed by a non printable character (including \n). The others should probably be adjusted for consistency, and to provide the translators with a single "escape-sequence" message.

Also, up to now we avoided using quotes when the culprit is the last guy on the line.

We should really write our conventions somewhere :(



reply via email to

[Prev in Thread] Current Thread [Next in Thread]