qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 02/40] pl050: rename pl050_keyboard_init() to pl050_kbd_init(


From: Peter Maydell
Subject: Re: [PATCH 02/40] pl050: rename pl050_keyboard_init() to pl050_kbd_init()
Date: Mon, 4 Jul 2022 14:12:59 +0100

On Wed, 29 Jun 2022 at 13:40, Mark Cave-Ayland
<mark.cave-ayland@ilande.co.uk> wrote:
>
> This is for consistency with all of the other devices that use the PS2 
> keyboard
> device.
>
> Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
> ---
>  hw/input/pl050.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/hw/input/pl050.c b/hw/input/pl050.c
> index c7980b6ed7..8e32b8ed46 100644
> --- a/hw/input/pl050.c
> +++ b/hw/input/pl050.c
> @@ -166,7 +166,7 @@ static void pl050_realize(DeviceState *dev, Error **errp)
>                            qdev_get_gpio_in_named(dev, "ps2-input-irq", 0));
>  }
>
> -static void pl050_keyboard_init(Object *obj)
> +static void pl050_kbd_init(Object *obj)
>  {
>      PL050State *s = PL050(obj);
>
> @@ -183,7 +183,7 @@ static void pl050_mouse_init(Object *obj)
>  static const TypeInfo pl050_kbd_info = {
>      .name          = "pl050_keyboard",
>      .parent        = TYPE_PL050,
> -    .instance_init = pl050_keyboard_init,
> +    .instance_init = pl050_kbd_init,
>  };

It's a static function so the name doesn't matter much, but
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>

thanks
-- PMM



reply via email to

[Prev in Thread] Current Thread [Next in Thread]