qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 3/8] hw/boards: Rename no_sdcard -> auto_create_sdcard


From: Thomas Huth
Subject: Re: [PATCH v2 3/8] hw/boards: Rename no_sdcard -> auto_create_sdcard
Date: Tue, 4 Feb 2025 19:19:08 +0100
User-agent: Mozilla Thunderbird

On 04/02/2025 19.07, Philippe Mathieu-Daudé wrote:
Invert the 'no_sdcard' logic, renaming it as the more explicit
"auto_create_sdcard". Machines are supposed to create a SD Card
drive when this flag is set. In many cases it doesn't make much
sense (as boards don't expose SD Card host controller), but this
is patch only aims to expose that nonsense; so no logical change
intended (mechanical patch using gsed).

Most of the changes are:

   -    mc->no_sdcard = ON_OFF_AUTO_OFF;
   +    mc->auto_create_sdcard = true;

Except in
  . hw/core/null-machine.c
  . hw/arm/xilinx_zynq.c
  . hw/s390x/s390-virtio-ccw.c
where the disabled option is manually removed (since default):
...
diff --git a/hw/arm/xilinx_zynq.c b/hw/arm/xilinx_zynq.c
index dc80181ea43..2d626a96b9b 100644
--- a/hw/arm/xilinx_zynq.c
+++ b/hw/arm/xilinx_zynq.c
@@ -463,11 +463,10 @@ static void zynq_machine_class_init(ObjectClass *oc, void 
*data)
      mc->desc = "Xilinx Zynq Platform Baseboard for Cortex-A9";
      mc->init = zynq_init;
      mc->max_cpus = ZYNQ_MAX_CPUS;
-    mc->no_sdcard = ON_OFF_AUTO_ON;
      mc->ignore_memory_transaction_failures = true;
      mc->valid_cpu_types = valid_cpu_types;
      mc->default_ram_id = "zynq.ext_ram";
-    mc->no_sdcard = ON_OFF_AUTO_OFF;
+    mc->auto_create_sdcard = true;

That's now wrong, too ... it should get removed (as you say in the patch description).

 Thomas




reply via email to

[Prev in Thread] Current Thread [Next in Thread]