[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v3 08/26] hw/core/loader: Add ROM loader notifier
From: |
Jean-Philippe Brucker |
Subject: |
Re: [PATCH v3 08/26] hw/core/loader: Add ROM loader notifier |
Date: |
Fri, 7 Feb 2025 15:57:39 +0000 |
On Tue, Feb 04, 2025 at 03:33:10PM +1000, Gavin Shan wrote:
> > diff --git a/include/hw/loader.h b/include/hw/loader.h
> > index 7f6d06b956..0cd9905f97 100644
> > --- a/include/hw/loader.h
> > +++ b/include/hw/loader.h
> > @@ -353,6 +353,21 @@ void *rom_ptr_for_as(AddressSpace *as, hwaddr addr,
> > size_t size);
> > ssize_t rom_add_vga(const char *file);
> > ssize_t rom_add_option(const char *file, int32_t bootindex);
> > +typedef struct RomLoaderNotify {
> > + /* Parameters passed to rom_add_blob() */
> > + hwaddr addr;
> > + size_t len;
> > + size_t max_len;
> > +} RomLoaderNotify;
> > +
>
> I would suggest to rename it to RomLoaderNotifyData since it's the
> data passed to the notifier.
Agreed
Thanks,
Jean