[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-ppc] [PATCH -V2 2/4] target-ppc: Use #define instead of openco
From: |
Alexander Graf |
Subject: |
Re: [Qemu-ppc] [PATCH -V2 2/4] target-ppc: Use #define instead of opencoding SLB valid bit |
Date: |
Thu, 22 Aug 2013 18:34:29 +0100 |
On 20.08.2013, at 11:49, Aneesh Kumar K.V wrote:
> From: "Aneesh Kumar K.V" <address@hidden>
Please fix your patch generation ;)
>
> Use SLB_ESID_V instead of (1 << 27) in the code
>
> Reviewed-by: Andreas Färber <address@hidden>
> Signed-off-by: Aneesh Kumar K.V <address@hidden>
Thanks, applied to ppc-next.
Alex
> ---
> target-ppc/mmu_helper.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/target-ppc/mmu_helper.c b/target-ppc/mmu_helper.c
> index 5dd4e05..9c9132e 100644
> --- a/target-ppc/mmu_helper.c
> +++ b/target-ppc/mmu_helper.c
> @@ -2061,7 +2061,7 @@ void helper_store_sr(CPUPPCState *env, target_ulong
> srnum, target_ulong value)
> /* ESID = srnum */
> rb |= ((uint32_t)srnum & 0xf) << 28;
> /* Set the valid bit */
> - rb |= 1 << 27;
> + rb |= SLB_ESID_V;
> /* Index = ESID */
> rb |= (uint32_t)srnum;
>
> --
> 1.8.1.2
>