qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [RFC 04/10] hw/mos6522: Rename timer callback functions


From: Mark Cave-Ayland
Subject: Re: [RFC 04/10] hw/mos6522: Rename timer callback functions
Date: Wed, 25 Aug 2021 08:11:37 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0

On 24/08/2021 11:09, Finn Thain wrote:

This improves readability.

Signed-off-by: Finn Thain <fthain@linux-m68k.org>
---
  hw/misc/mos6522.c | 10 ++++++----
  1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/hw/misc/mos6522.c b/hw/misc/mos6522.c
index 1d4a56077e..c0d6bee4cc 100644
--- a/hw/misc/mos6522.c
+++ b/hw/misc/mos6522.c
@@ -154,7 +154,7 @@ static void mos6522_timer2_update(MOS6522State *s, 
MOS6522Timer *ti,
      }
  }
-static void mos6522_timer1(void *opaque)
+static void mos6522_timer1_expired(void *opaque)
  {
      MOS6522State *s = opaque;
      MOS6522Timer *ti = &s->timers[0];
@@ -164,7 +164,7 @@ static void mos6522_timer1(void *opaque)
      mos6522_update_irq(s);
  }
-static void mos6522_timer2(void *opaque)
+static void mos6522_timer2_expired(void *opaque)
  {
      MOS6522State *s = opaque;
      MOS6522Timer *ti = &s->timers[1];
@@ -445,8 +445,10 @@ static void mos6522_init(Object *obj)
          s->timers[i].index = i;
      }
- s->timers[0].timer = timer_new_ns(QEMU_CLOCK_VIRTUAL, mos6522_timer1, s);
-    s->timers[1].timer = timer_new_ns(QEMU_CLOCK_VIRTUAL, mos6522_timer2, s);
+    s->timers[0].timer = timer_new_ns(QEMU_CLOCK_VIRTUAL,
+                                      mos6522_timer1_expired, s);
+    s->timers[1].timer = timer_new_ns(QEMU_CLOCK_VIRTUAL,
+                                      mos6522_timer2_expired, s);
  }
static void mos6522_finalize(Object *obj)

I'm not overly keen on this one: the general QEMU convention for a timer callback is for it to be named *_timer() rather than *_expired(), so I'd prefer to keep this consistent with the rest of the codebase.


ATB,

Mark.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]