[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 01/11] hw/s390/ccw-device: Convert to three-phase reset
From: |
Peter Maydell |
Subject: |
[PATCH v2 01/11] hw/s390/ccw-device: Convert to three-phase reset |
Date: |
Fri, 30 Aug 2024 15:58:02 +0100 |
Convert the TYPE_CCW_DEVICE to three-phase reset. This is a
device class which is subclassed, so it needs to be three-phase
before we can convert the subclass.
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
---
hw/s390x/ccw-device.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/hw/s390x/ccw-device.c b/hw/s390x/ccw-device.c
index a7d682e5af9..14c24e38904 100644
--- a/hw/s390x/ccw-device.c
+++ b/hw/s390x/ccw-device.c
@@ -44,9 +44,9 @@ static Property ccw_device_properties[] = {
DEFINE_PROP_END_OF_LIST(),
};
-static void ccw_device_reset(DeviceState *d)
+static void ccw_device_reset_hold(Object *obj, ResetType type)
{
- CcwDevice *ccw_dev = CCW_DEVICE(d);
+ CcwDevice *ccw_dev = CCW_DEVICE(obj);
css_reset_sch(ccw_dev->sch);
}
@@ -55,11 +55,12 @@ static void ccw_device_class_init(ObjectClass *klass, void
*data)
{
DeviceClass *dc = DEVICE_CLASS(klass);
CCWDeviceClass *k = CCW_DEVICE_CLASS(klass);
+ ResettableClass *rc = RESETTABLE_CLASS(klass);
k->realize = ccw_device_realize;
k->refill_ids = ccw_device_refill_ids;
device_class_set_props(dc, ccw_device_properties);
- dc->reset = ccw_device_reset;
+ rc->phases.hold = ccw_device_reset_hold;
dc->bus_type = TYPE_VIRTUAL_CSS_BUS;
}
--
2.34.1
- [PATCH v2 00/11] s390: Convert virtio-ccw, cpu to three-phase reset, and followup cleanup, Peter Maydell, 2024/08/30
- [PATCH v2 01/11] hw/s390/ccw-device: Convert to three-phase reset,
Peter Maydell <=
- [PATCH v2 02/11] hw/s390/virtio-ccw: Convert to three-phase reset, Peter Maydell, 2024/08/30
- [PATCH v2 04/11] hw: Remove device_class_set_parent_reset(), Peter Maydell, 2024/08/30
- [PATCH v2 05/11] target/alpha, hppa: Remove unused parent_reset fields, Peter Maydell, 2024/08/30
- [PATCH v2 06/11] hw: Define new device_class_set_legacy_reset(), Peter Maydell, 2024/08/30
- [PATCH v2 03/11] target/s390: Convert CPU to Resettable interface, Peter Maydell, 2024/08/30
- [PATCH v2 08/11] hw: Rename DeviceClass::reset field to legacy_reset, Peter Maydell, 2024/08/30
- [PATCH v2 10/11] hw/core/qdev: Simplify legacy_reset handling, Peter Maydell, 2024/08/30
- [PATCH v2 09/11] hw: Remove device_phases_reset(), Peter Maydell, 2024/08/30
- [PATCH v2 11/11] hw/core/resettable: Remove transitional_function machinery, Peter Maydell, 2024/08/30
- [PATCH v2 07/11] hw: Use device_class_set_legacy_reset() instead of opencoding, Peter Maydell, 2024/08/30